Senseboard: Getting it working with Ubuntu

So I received my first delivery for the TU100 course given by the open university as part of starting a degree with them. Unfortunately the initial installation of the Ubuntu packages did not work, however after some chatting on the OU forums it appears there is an answer to my woes.

I have decided that some others might benefit from a little tutorial. So thank you to @grahams_retro for this little gem that has solved my problems running the sense software under Ubuntu. This should work for all Linux distributions but please leave a comment if you find any problems. Firstly run the following from a terminal emulator such as XTerm or Gnome Terminal

/usr/bin/sense.sh

This will launch the sense application, you then need to click open and choose the Open University “Test your setup” file. Once this is open click the green flag in the upper right corner, this may cause a dialog to appear saying that the sense board cannot be contacted. At this point go back to the terminal and check for errors, you will see something like the following.

Error opening serial port /dev/ttyUSB0 - Permission denied(13).
Error opening serial port /dev/ttyUSB0 - Permission denied(13).
Error opening serial port /dev/ttyUSB0 - Permission denied(13).
Error opening serial port /dev/ttyUSB0 - Permission denied(13).

While still in the terminal hold the CTRL button and press C, this will stop sense and allow you to type in another command. Now type in the following, replacing ttyUSB0 with the equivelent listed in the output of the previous command.

ls -l /dev/ | grep ttyUSB0

This should output something along the lines of this.

crw-rw----  1 root dialout   188,   0 Sep 17 22:52 ttyUSB0

The word just after root indicates the group that has the needed rights to access the sense board. So to allow your own user access to the sense board you need to add your username to the listed group. Firstly make sure you know your username, to do this run the following from the terminal.

whoami

This will display on a single line the account username. You will then need to run the following command replacing dialout with the appropriate group as obtained above and username with your user account username.

sudo usermod -a -G dialout username

You might be asked for your sudo password, this is the same as your user account password. The command will add your user to the correct group, to test this has worked properly run this command from the terminal.

id username | grep dialout

If this does not return anything then there has been a problem and you may need to go back a few steps and ensure you have entered the correct information. If everything has gone to plan you should get something like the following.

gid=1000(username) groups=1000(username),4(adm),20(dialout),24(cdrom),27(sudo),30(dip),46(plugdev),108(lpadmin),124(sambashare)

You should now be able to run sense within your Linux installation and interact with the sense board without any problems. If you find any problems try rebooting your computer first and if you have further issues just comment at the bottom and I will try to offer some help.

This post has been viewed 5029 times.

7 thoughts on “Senseboard: Getting it working with Ubuntu

  1. Thanks, after following the instructions and performing a reset mine still did not work.

    However, further testing by clicking on the “extras” button in the sense software and choosing “show SenseBoard watcher” I could see that it was working. Clicking on the various icons in stage 1 (those icons beneath the picture of the board in the test script) I could see it was working fine. I closed the script and reloaded it and this time it worked fine.

  2. Thanks for this, installed Mint 15 tonight and had an issue setting the senseboard up, I hope I can work out things like this for myself one day, I know my way around windows well enough working in IT support, but wouldn’t have had a clue how to troubleshoot this! 🙂

  3. Hi Lawrence, I followed your instructions, but after inputting “ls -l /dev/ | grep ttyUSB0” I only get “ttyUSB0” in red text in the terminal, instead of the line you specify, which gives the group. Then when i follow the other instructions nothing happens. Can you help me with this? Don

    1. Of course I can try and give you a hand. Which distribution of Linux are you using? If you’re not sure please try running “uname -a” and “cat /etc/version; cat /proc/version” one of those should tell you. Also did you run the command you list when the SenseBoard was plugged in?

Leave a Reply

Your email address will not be published. Required fields are marked *